Aurix Exchange

HyperEA need Educating

strmac

Member


results:


Thanks in advance big brains
 

radicaltour

Moderator
VIP Member
i looked at the code and it seems that it shoudl already be educated.
Have you tried it on demo or live? what's the error you're getting?
 

mopips

New member
Can't seem to get it profitable on backtest. Anyone have good settings to match those excellent posted results?
 

jyrik

Member
Hey
Does someone have settings file.
Im getting error when trying to backtest it. Replaced some text and it showd me that error is ERR_INCORRECT_SERIES_ARRAY_USING error 4054. Could someone fix it?
 

jyrik

Member
It shows it in backtesting.
bool CheckForSignal(int ai_0) {
double l_irsi_4 = iRSI(Symbol(), PERIOD_M1, Rsi1Period, PRICE_CLOSE, 0);
double l_irsi_12 = iRSI(Symbol(), Period(), Rsi15Period, PRICE_CLOSE, 0);
double l_ima_20 = iMA(Symbol(), Period(), MaPeriod, 0, MODE_SMA, PRICE_MEDIAN, 1);
double l_icci_28 = iCCI(Symbol(), Period(), Rsi15Period, PRICE_CLOSE, 0);
double l_icci_36 = iCCI(Symbol(), PERIOD_M1, Rsi1Period, PRICE_CLOSE, 0);
double ld_44 = GetLastPrice();
int li_52 = GetOrdersCount();
if (li_52 == 0 && ai_0 == 0 && isBuy()) return (TRUE);
if (li_52 == 0 && ai_0 == 1 && isSell()) return (TRUE);
int l_count_56 = 0;
if (ExistPosition(OP_BUY)) l_count_56++;
else l_count_56 += 2;
if (ExistPosition(OP_SELL)) l_count_56 += 10;
else l_count_56 += 20;
if (ChecksDeals(0)) l_count_56 += 100;
else l_count_56 += 200;
if (ChecksDeals(1)) l_count_56 += 1000;
else l_count_56 += 2000;
if (UseLong) l_count_56 += 10000;
else l_count_56 += 20000;
if (UseShort) l_count_56 += 100000;
else l_count_56 += 200000;
if (UseExtraSignal) l_count_56 += 1000000;
else l_count_56 += 2000000;
int li_60 = CheckOrders(li_52, l_count_56, Ask, Bid, ld_44, PipsForOpenMore, Point, l_irsi_12, l_irsi_4, Rsi15Div, Rsi1Div, l_ima_20, ChannelWidthBuy, ChannelWidthSell, ai_0, g_low_704, g_high_696, BuyCorrection, SellCorrection, l_icci_36, l_icci_28);
switch (li_60) {
case 0:
return (FALSE);
case 1:
return (TRUE);
}
Print("Error code: ", -li_60);
Print(GetTerminalTitleFromDll());
return (FALSE);
}

This is giving me an error when backtesting??
 

jyrik

Member
Could someone post here somekind of set files that I could see if my mt4 isnt giving with it any errors
 
sorry i could upload it it says invalid file anyhow if somebody is still interested in the set file just put your email and i mail it
 

jyrik

Member
Ok here is my email
jyrika at gmail.com
And could you post you hyper ea version also and dll file.
Thank you very much.
 

stovedude

Active member
You'll need to zip the .set file into a .zip or .rar file to upload. Try the jZip program if you don't have one.

 

awalker

Member
sorry i could upload it it says invalid file anyhow if somebody is still interested in the set file just put your email and i mail it

Hi yes I'm interested in a set file that works. I cannot get the EA to place any trades whatsoever either back/forward with the default set file (no errors just no trades).

awalker at btinternet.com
 

awalker

Member
I just don't get it, no trades in 5 year backtest. Says account checking complete, has smiley face etc. etc. but still no sign of a trade. I've tried ECN true/false can't see any other parameter that may stop it trading completely. Anybody got any ideas ?
 

Aurix Exchange
Top